using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?:\/\/[^\s]+?\.[^\s]+)$";
string substitution = @"<a href=""$1"">auto link</a>";
string input = @"http://example.com
https://example.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}