#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)"
Local $sString = "http://site.ru/msk/page" & @CRLF & _
"http://site.ru/spb/page" & @CRLF & _
"http://site.ru/region/page" & @CRLF & _
"http://site.ru/page" & @CRLF & _
"" & @CRLF & _
"http://site.ru/aasfa32page" & @CRLF & _
"" & @CRLF & _
"http://site.ruaasfa32/page" & @CRLF & _
"" & @CRLF & _
"http://site.ru/aasfa32/page" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")