import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http:\\/\\/site.ru(\\/)*(msk|spb|region)*\\/page)";
final String string = "http://site.ru/msk/page\n"
+ "http://site.ru/spb/page\n"
+ "http://site.ru/region/page\n"
+ "http://site.ru/page\n\n"
+ "http://site.ru/aasfa32page\n\n"
+ "http://site.ruaasfa32/page\n\n"
+ "http://site.ru/aasfa32/page\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}