# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)"
test_str = ("http://site.ru/msk/page\n"
"http://site.ru/spb/page\n"
"http://site.ru/region/page\n"
"http://site.ru/page\n\n"
"http://site.ru/aasfa32page\n\n"
"http://site.ruaasfa32/page\n\n"
"http://site.ru/aasfa32/page\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.