const regex = /(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http:\\\/\\\/site.ru(\\\/)*(msk|spb|region)*\\\/page)', 'g')
const str = `http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}