re = /(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)/
str = 'http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end