using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)";
string input = @"http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}