import Foundation
let pattern = #"(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)