package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)`)
var str = `http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}