use strict;
my $str = 'http://site.ru/msk/page
http://site.ru/spb/page
http://site.ru/region/page
http://site.ru/page
http://site.ru/aasfa32page
http://site.ruaasfa32/page
http://site.ru/aasfa32/page
';
my $regex = qr/(http:\/\/site.ru(\/)*(msk|spb|region)*\/page)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}