# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/page\\/)\d+/$11/;t' <<< "http://retail.domain.co.uk/view_orders/page/6/10?type=completed"