re = /(\/page\/)\d+/
str = 'http://retail.domain.co.uk/view_orders/page/6/10?type=completed'
subst = '$11'
result = str.sub(re, subst)
# Print the result of the substitution
puts result