// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/page\/)\d+").unwrap();
let string = "http://retail.domain.co.uk/view_orders/page/6/10?type=completed";
let substitution = "$11";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}