use strict;
my $str = 'http://retail.domain.co.uk/view_orders/page/6/10?type=completed';
my $regex = qr/(\/page\/)\d+/p;
my $subst = '$11';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";