const regex = /(\/page\/)\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/page\\\/)\\d+', '')
const str = `http://retail.domain.co.uk/view_orders/page/6/10?type=completed`;
const subst = `$11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);