# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/_\d+$//gm;t' <<< "HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
"