#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)_\d+$"
Local $sString = "HTA10_07_001" & @CRLF & _
"HTA10_07_001" & @CRLF & _
"HTA10_07_006" & @CRLF & _
"HTA10_07_006" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)