// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_\d+$").unwrap();
let string = "HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}