use strict;
my $str = 'HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
';
my $regex = qr/_\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";