package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_\d+$`)
var str = `HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}