$re = '/_\d+$/m';
$str = 'HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;