re = /_\d+$/m
str = 'HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result