using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_\d+$";
string substitution = @"";
string input = @"HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}