const regex = new RegExp('_\\d+$', 'gm')
const str = `HTA10_07_001
HTA10_07_001
HTA10_07_006
HTA10_07_006
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);