# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(url\(['"]?)(?:\.\.\\/|http:\\/\\/[^)]*\\/)?/$1file:\/\/dir\/first\//gm;t' <<< "url(\"assets/images/pic.jpg\")
url('assets/images/pic.jpg')
url(\"../images/pic.jpg\")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
"