const regex = /(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(url\\([\'"]?)(?:\\.\\.\\\/|http:\\\/\\\/[^)]*\\\/)?', 'gm')
const str = `url("assets/images/pic.jpg")
url('assets/images/pic.jpg')
url("../images/pic.jpg")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
`;
const subst = `$1file://dir/first/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);