use strict;
my $str = 'url("assets/images/pic.jpg")
url(\'assets/images/pic.jpg\')
url("../images/pic.jpg")
url(../images/pic.jpg)
url(\'../images/pic.jpg\')
url(\'http://website.com/images/pic.jpg\')
';
my $regex = qr/(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?/mp;
my $subst = '$1file://dir/first/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";