#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?"
Local $sString = "url("assets/images/pic.jpg")" & @CRLF & _
"url('assets/images/pic.jpg')" & @CRLF & _
"url("../images/pic.jpg")" & @CRLF & _
"url(../images/pic.jpg)" & @CRLF & _
"url('../images/pic.jpg')" & @CRLF & _
"url('http://website.com/images/pic.jpg')" & @CRLF & _
""
Local $sSubst = "$1file://dir/first/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)