package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?`)
var str = `url("assets/images/pic.jpg")
url('assets/images/pic.jpg')
url("../images/pic.jpg")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
`
var substitution = "$1file://dir/first/"
fmt.Println(re.ReplaceAllString(str, substitution))
}