import Foundation
let pattern = #"(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
url("assets/images/pic.jpg")
url('assets/images/pic.jpg')
url("../images/pic.jpg")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1file://dir/first/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)