$re = '/(url\([\'"]?)(?:\.\.\/|http:\/\/[^)]*\/)?/m';
$str = 'url("assets/images/pic.jpg")
url(\'assets/images/pic.jpg\')
url("../images/pic.jpg")
url(../images/pic.jpg)
url(\'../images/pic.jpg\')
url(\'http://website.com/images/pic.jpg\')
';
$subst = "$1file://dir/first/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;