using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(url\(['""]?)(?:\.\.\/|http:\/\/[^)]*\/)?";
string substitution = @"$1file://dir/first/";
string input = @"url(""assets/images/pic.jpg"")
url('assets/images/pic.jpg')
url(""../images/pic.jpg"")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}