// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(url\(['"]?)(?:\.\.\/|http:\/\/[^)]*\/)?"#).unwrap();
let string = "url(\"assets/images/pic.jpg\")
url('assets/images/pic.jpg')
url(\"../images/pic.jpg\")
url(../images/pic.jpg)
url('../images/pic.jpg')
url('http://website.com/images/pic.jpg')
";
let substitution = "$1file://dir/first/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}