# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="header-info-box">\K((?:[^<]|(?!<\/?div).|<div(?1)<\/div>)*+)/<div class="hello"><\/div>/gm;t' <<< "
<div class=\"header-info-box\">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
"