$re = '~<div class="header-info-box">\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)~m';
$str = '
<div class="header-info-box">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
';
$subst = "<div class=\"hello\"></div>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;