re = /<div class="header-info-box">\K((?:[^<]|(?!<\/?div).|<div(?1)<\/div>)*+)/m
str = '
<div class="header-info-box">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
'
subst = '<div class="hello"></div>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result