#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<div class="header-info-box">\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)"
Local $sString = "" & @CRLF & _
"<div class="header-info-box">" & @CRLF & _
" Разный контент, <span> включая теги</span>" & @CRLF & _
" <div> " & @CRLF & _
" <div> </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<div class="hello"></div>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)