using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""header-info-box"">\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)";
string substitution = @"<div class=""hello""></div>";
string input = @"
<div class=""header-info-box"">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}