import re
regex = re.compile(r"<div class=\"header-info-box\">\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)", flags=re.MULTILINE)
test_str = ("\n"
"<div class=\"header-info-box\">\n"
" Разный контент, <span> включая теги</span>\n"
" <div> \n"
" <div> </div>\n"
" </div>\n"
"</div>\n\n")
subst = "<div class=\"hello\"></div>"
result = regex.sub(subst, test_str)
if result:
print(result)