const regex = new RegExp('<div class="header-info-box">\\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)', 'gm')
const str = `
<div class="header-info-box">
Разный контент, <span> включая теги</span>
<div>
<div> </div>
</div>
</div>
`;
const subst = `<div class="hello"></div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);