import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"header-info-box\">\\K((?:[^<]|(?!</?div).|<div(?1)</div>)*+)";
final String string = "\n"
+ "<div class=\"header-info-box\">\n"
+ " Разный контент, <span> включая теги</span>\n"
+ " <div> \n"
+ " <div> </div>\n"
+ " </div>\n"
+ "</div>\n\n";
final String subst = "<div class=\"hello\"></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}