# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d),(?=\d)/./g;t' <<< "00:00:00,166 --> 00:00:03,999 In this section we will look at"