const regex = /(?<=\d),(?=\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d),(?=\\d)', 'g')
const str = `00:00:00,166 --> 00:00:03,999 In this section we will look at`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);