import Foundation
let pattern = #"(?<=\d),(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"00:00:00,166 --> 00:00:03,999 In this section we will look at"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)