use strict;
my $str = '00:00:00,166 --> 00:00:03,999 In this section we will look at';
my $regex = qr/(?<=\d),(?=\d)/p;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";