import re
regex = re.compile(r"(?<=\d),(?=\d)")
test_str = "00:00:00,166 --> 00:00:03,999 In this section we will look at"
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)