re = /(?<=\d),(?=\d)/
str = '00:00:00,166 --> 00:00:03,999 In this section we will look at'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result