$re = '/(?<=\d),(?=\d)/';
$str = '00:00:00,166 --> 00:00:03,999 In this section we will look at';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;