# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\bREF)(?!:)/:/gm;t' <<< "DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*
"