import Foundation
let pattern = #"(?<=\bREF)(?!:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DBZ:00000*{6000}/ONE/REFFERRARO REF:FINE DOGS*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)